Try MAXST AR Fusion Tracker Now ✨
List
Target Marker not recognized after App restart
Posted Date: 2020-07-22 14:04     Edited Date: 2020-07-27 2:31     Writer: dominik.leonhardt

1. SDK Version: 5.0.2
2. Development Environment: Unity-Android
3. Tracker/Scanner: ImageTracker
4. License Type(Free / Pro-One Time Fee / Pro-Subscription / Enterprise): Pro
5. Target Device(Optional): Samsung Tablet

Hi, the App works 100% perfect after "build and run" it out of Unity on our Android Tablet. We can scan our Target Markers and everything works fine. After closing and re-opening the App the camera won't recognize any of our Target markers. The rest of the app still works 100% ( main menu, overlay, camera etc.) but when i frame a target image nothing happens. Maybe something went wrong with installing the app on the phone? Targets are missing ? I dont know.... The App worked on iOS and on previous Andorid Versions. We split the App into a .apk and .obb. and load the scene start, but althought this worked in a preivous build of the app.

Thanks for your help,

Marc

Posted Date: 2020-07-23 9:11     Edited Date: 2020-07-23 9:11     Writer: sjkim

Thanks for your interest to our MAXST AR SDK.

 

Could you please share logs to fix the recognize issue?

And then, Could you share me the Tablet model, you used when testing?

If so, our can get it. we can help you more easily.

 

If you have other questions, feel free to questions us.

 

 

Best regards

Francisco

MAXST Support Team

Posted Date: 2020-07-23 10:01     Edited Date: 2020-07-23 10:01     Writer: dominik.leonhardt

Hey,

thanks for replying.

Which logs you want ? We already tried to debug it with Android Studio but couldnt find anything wrong. And how can I share the logs ?

The Tablet we are using is a Samsung GalaxyTab S5e but we already tested it with another Andorid Smartphone and there is the same issue. So we think its not specific to the Tablet. Maybe the target marker date is not sotred correctly to the phone or in a wrong loaction where we cant acces it ? But why is it working than on first start with the cabel connected to the PC. Is it possible that the Target Markes are in some kind of cache ? And this cache gets cleared after closing the app?

 

Thanks,

Marc

Posted Date: 2020-07-27 2:28     Edited Date: 2020-07-27 2:31     Writer: sjkim

Please copy a logcat from Android Studio. We wanna check logs.

Could you please share logs from app start to quit the app through Android Studio.

 

And then, I want to test on the same Android version, what is the Android version you are using?

 

There isn't store at cache for the target image required to recognize the target.

In Image Tracker, you just need to load the target image(2dmap) in StreamingAssets/MaxstAR/Your_TargetGroup.

 

 

If you have other questions, feel free to questions us.

 

 

Best regards

Francisco

MAXST Support Team