Try MAXST AR Fusion Tracker Now ✨
List
unity iOS xcode 빌드 오류
Posted Date: 2020-08-28 6:01     Edited Date: 2020-09-03 8:21     Writer: shimaz.bsh

Please provide your development details as below;

1. SDK Version: 5.0.2
2. Development Environment: unity-ios
3. Xcode Version: 11.6

타사 AR솔루션에서 맥스트로 이전 작업을 하고 있습니다. 

일부 기능 테스트를 위해 ios로 빌드하려는데 빌드 에러가 발생하여 진행하지 못 하고 있습니다. 

포럼내의 다른 글을 참고하여 accelerate 와 arkit 프레임 워크도 embed & sign으로 추가했습니다만 에러는 동일하게 나옵니다. 

 

해결이 잘 되지 않아 같은 방식으로 Maxst AR Unity SDK 내의 샘플을 빌드해도 같은 오류가 납니다. 

어떻게 해야 할까요. 

Posted Date: 2020-09-01 2:19     Edited Date: 2020-09-01 2:19     Writer: sjkim

MAXST에 관심을 가져주셔서 감사합니다. 

 

라이브러리가 링킹이 안되서 발생한 문제 같습니다. 

라이브러리가 있는 폴더를 [Build Settings]-[Library Search Paths]에 추가하시고,

[Build Settings]-[Other Linker Flags]에 -l (라이브러리 이름)를 추가하세요.

 

또한 개발하기 위한 최소 사항은 확인하셨나요? 

확인을 하지 못하셨더면 아래의 최소 사항을 확인하시기 바랍니다. 

  - Unity : Unity 2017.1 이상

  - iOS : iOS 9.0 이상

  - macOS : macOS 10.10 이상

 

추가적인 질문이 있으시면 언제든지 문의주세요.

 

 

Best regards

Francisco

MAXST Support Team

Posted Date: 2020-09-03 8:21     Edited Date: 2020-09-03 8:21     Writer: ominseok

유니티에서 Assets/Plugins/iOS/libMaxstAR.a의 Import Settings에서 ARKit과 Accelerate를 추가하고 Apply를 누르고 빌드해보세요.