Try MAXST AR Fusion Tracker Now ✨
List
Object Tracking Error when importing a map
Posted Date: 2020-12-12 18:33     Edited Date: 2020-12-16 2:41     Writer: necktarios.black

1. SDK Version: 5.0.2
2. Development Environment: Unity-Android
3. Tracker/Scanner: Object Tracker
4. License Type: Free
5. Target Device(Optional): Epson Moverio BT-350, Samsung Galaxy Tab S4
 

Hello everyone, i was developing my application with no issues until yesterday when the object tracking just freaked out. First, my buttons started not working. So I did all the troubleshooting  methods until i decided to make a separate canvas for every button group, in order to make my life easier. Then the object tracker started giving me multiple errors. I deleted my object trackable and imported a new one, which gives me another error. The current error:

NullReferenceException: Object reference not set to an instance of an object
maxstAR.MapRendererBehaviour.CreateAnchors (maxstAR.TagAnchor[] anchors) (at Assets/MaxstAR/Script/Wrapper/MapRendererBehaviour.cs:150)
maxstAR.AbstractMapViewerBehaviour.Load (System.String fileName, System.Single knownLength) (at Assets/MaxstAR/Script/Wrapper/AbstractMapViewerBehaviour.cs:118)
maxstAR.ObjectTrackableEditor.Load (System.String fileName, System.Single realSize) (at Assets/MaxstAR/Editor/ObjectTrackableEditor.cs:27)
maxstAR.ObjectTrackableEditor.OnInspectorGUI () (at Assets/MaxstAR/Editor/ObjectTrackableEditor.cs:133)
UnityEditor.UIElements.InspectorElement+<>c__DisplayClass58_0.<CreateIMGUIInspectorFromEditor>b__0 () (at <a8e33794c0064f2aa201ade069162226>:0)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

 

If anyone has any idea about this, would be really helpfull!

Posted Date: 2020-12-14 4:33     Edited Date: 2020-12-14 4:33     Writer: sjkim

Thanks for your interest in our MAXST AR SDK.

 

Which button doesn't working?

What did you do with your purpose?

 

Please describe detailed information about the issue.

 

 

Best regards,

Francisco

MAXST Support Team

Posted Date: 2020-12-14 17:58     Edited Date: 2020-12-14 17:58     Writer: necktarios.black

Hello,

all my buttons from a canvas didn't work but that was not the issue. I think that some file, that i never actually found, got corrupted so that was the outcome. I made a new projet with the same code and worked, so my problem is solved now. I have another question though. Is it possible to add a 3d model at runtime? Let's say that i read my 3d models from a server when i open the application. Is it possible for me to add models to the server in order to update the models in the application? Thank you very much for your time, Nektarios

Posted Date: 2020-12-16 2:41     Edited Date: 2020-12-16 2:41     Writer: sjkim

The Object Tracker, can import the trained space or environment you have mapped and saved with Visual SLAM,

and augment the content in the desired position.

 

However, if you are using an Enterprise license, you can add 3dmap at runtime.

 

Best regards,

Francisco

MAXST Support Team