Try MAXST AR Fusion Tracker Now ✨
List
Black screen on Android build
Posted Date: 2021-03-12 0:22     Edited Date: 2021-03-13 10:30     Writer: georgi

Please provide your development details as below;

1. SDK Version: 5.0.3
2. Development Environment: Unity-Android, Unity-iOS
3. Tracker/Scanner: Image tracker
4. License Type: Free
5. Target Device(Optional): 

We can assist better if you attach screenshots of issues.

Screenshot: https://ibb.co/ypdGGXF

 

Hi,

I build my app to Android device and everything is working (all the menus and buttons), but when I try to open the camera (I have a button in my app for "entering" AR) it shows black screen and crashes. In Unity editor everything is fine, but when I build it on android it chashes even before asking for permissions for the camera. I've tried bulding the sample scene from the sdk but the result is the same. I'm using Unity 2020.1.17f1, and tried building the sample scene with Unity 2019.3.0 - the camera is working (but not displaying any content when trying to scan image target). 

I've tried building it on several devices (also on virtual android emulators) and the result is all the same. 

Posted Date: 2021-03-12 4:51     Edited Date: 2021-03-12 4:51     Writer: sjkim

Thank you for your interest in MAXST AR SDK.

 

This issue is related a AR Core bug.

We will update a as soon as possible through MAXST AR SDK 5.0.4.

 

But, If you temporarily install XR plugin and set ARCore, the app is working.

 

If you have related AR SDK questions, feel free to ask.

 


 
Best regards,

Francisco

MAXST Support Team

Posted Date: 2021-03-12 10:43     Edited Date: 2021-03-12 10:43     Writer: georgi

Hi,

Thank you for your fast reply.

I've tried your temporarily solution but after installing XR plugin it gives me error when trying to buld the app:
"A failure occured while executing com.android.build.gradle.internal.tasks.Worker$ActionFacade See the Console for details"

 

 

Posted Date: 2021-03-13 10:30     Edited Date: 2021-03-13 10:30     Writer: georgi

Hi,

Can you help me with that problem?