Try MAXST AR Fusion Tracker Now ✨
List
Outdated Protobuf version on building for IOS Unity 2020.3
Posted Date: 2021-07-20 19:00     Edited Date: 2021-07-21 4:55     Writer: rimoldi98

Please provide your development details as below;

1. SDK Version: 5.0.5
2. Development Environment: Unity-iOS
3. Tracker/Scanner:
4. License Type: Free
5. Target Device(Optional):

After building the project in Unity, xCode throws the following error:

/Volumes/build-storage/build/3_4_iOS-mac/opencv/3rdparty/protobuf/src/google/protobuf/stubs/common.cc:68] This program requires version 3.10.0 of the Protocol Buffer runtime library, but the installed version is 3.5.1. Please update your library. If you compiled the program yourself, make sure that your headers are from the same version of Protocol Buffers as your link-time library

We tried updating the system installed Protobuf version to 3.17, but the error keeps showing up.

We are also using Google Cardboard 1.6 and URP

Posted Date: 2021-07-21 4:55     Edited Date: 2021-07-21 4:55     Writer: sjkim

Thank you for your interest in MAXST.

 

Currently, We don't official support a VR(Google Cardboard and URP).

So, you can't use both MAXST AR SDK and VR.

 

If you have related the MAXST SDK questions, feel free to ask.

 


 
Best regards,

Francisco

MAXST Support Team