Unity samples not working, camera shows Gray
Posted Date: 2023-01-25 12:36     Edited Date: 2023-02-14 7:47     Writer: fabcap83

Dear MAXST Forum, 

i was doing my very pleriminary steps with MAXST for Unity. I followed the set up documentation, managed to resolve some few issues on the way. 

If I run the sample in unity by clicking the play button or i deploy it as an app on my Android device it does not show the camera content but only a gray background. 

Am I missing anything? Can anyone help me out? 

Screenshot_20230122_234023_MAXST Image Test.jpg

My Scene looks good to me and ARCamera seems to pick the camera image, as you can see i also tried to add a cube over the camera, but that does not show either in the play mode, it would appear almost as the sample would not be picking the ARCamera but some other camera instead, i don't have any other camera in the scene thought.   



1. SDK Version: 5.0.2
2. Development Environment: Unity-Android
3. Tracker/Scanner: i am not using any tracker yet as it is failing with the camera 
4. License Type: free
5. Target Device(Optional): Samsung Galaxy S20 

Posted Date: 2023-01-30 1:45     Edited Date: 2023-01-30 1:46     Writer: sjkim

Thank you for your interest in MAXST AR SDK.


By any chance, is the Android API level of the device higher than 31?

This part was a problem that occurred when the android OS was upgraded, but it was resolved in MAXST AR SDK 5.0.7.


Please download MAXST AR SDK 5.0.7 from the link below.


If you have related the MAXST AR SDK questions, feel free to ask.


Best regards,


MAXST Support Team

Posted Date: 2023-01-30 7:34     Edited Date: 2023-01-30 7:37     Writer: fabcap83

Hi Francisco, 

thank you for your reply. 

Unfortunately it does not seem to depend on that. 

I made a new sample yesterday following exactly the instructions in the video tutorial, i did not change it to android and while playing it inside Unity i had exactly the same behavior. Now i tried to set it to android 11, nothing changed. 

I can still upgrade the sdk to the latest if the one I have is defect.

Can you think on anything else? 

In the new sample i can see from the scene view, that the ARCamera is actually working and tracking an image, but in player mode i see only a gray screen even thoguht the logs indicate success! 



Posted Date: 2023-02-14 7:46     Edited Date: 2023-02-14 7:47     Writer: sjkim

Sorry for the late reply.

This can be solved by changing the Depth value to a positive number greater than 1 in the ARCamera Inspector window.


If you have related the MAXST AR SDK questions, feel free to ask.


Best regards,


MAXST Support Team