Space Tracker
Posted Date: 2023-12-28 19:04     Edited Date: 2024-01-29 13:14     Writer: info

Please provide your development details as below;

1. SDK Version: 6.2.0
2. Development Environment: Unity-Android
3. Tracker/Scanner: Space Tracker
4. License Type(Free / Pro-One Time Fee / Pro-Subscription / Enterprise): Pro-One Time Fee
5. Target Device(Optional): iPad Pro 2020

We can assist better if you attach screenshots of issues.



I was folowing instructions, but i got nothing after i pressed "Load" button. I got two new files: "object", "planes", but i don't see anything on the screen.

Posted Date: 2023-12-29 23:29     Edited Date: 2023-12-29 23:32     Writer: sejin

Thank you for your interest in MAXST AR SDK.

First, make sure your camera isn't too far away or looking from the outside of the Object to see it. Move the camera so that it is looking at the center of the Object.

Textures may be broken if your project was created in URP mode. In this case, modify the shader appropriately for URP in Assets/MaxstAR/OBJLoader/OBJLoader.cs > DefineMaterial function. (For example, Shader.Find("Universal Render Pipeline/Lit"))

If the above two methods do not result in spatial objects appearing correctly in your scene, please send your spatial data to We will get back to you after checking.


If you have any questions, feel free to ask.

Thank you.

Best regards,


MAXST Support Team

Posted Date: 2023-12-30 7:58     Edited Date: 2023-12-30 7:58     Writer: info

Thank you. My camera isn't too far away. And it isn't URP project.

Posted Date: 2023-12-30 9:58     Edited Date: 2023-12-30 9:58     Writer: sejin

All the files I provided loaded fine in the Unity Editor.
You said that you don't see anything on the screen when you click load. Do you mean that the Unity Editor doesn't show anything in the scene?
If not, does that mean that when you run the app on mobile after the build and point the camera at the space, it doesn't recognize the space properly and therefore doesn't augment the content properly?

If you could answer this, I would be able to give a more accurate answer.


Best regards,


MAXST Support Team

Posted Date: 2023-12-30 10:20     Edited Date: 2023-12-30 10:20     Writer: info

I mean i don't see the spatial object in Unity Editor Window "Scene". I would like to set up everything on the spatial object in Unity Editor "Scene" before using mobile app.

Posted Date: 2023-12-30 10:45     Edited Date: 2023-12-30 10:45     Writer: info

May be i need some specific settings for my project, or specific version of Unity or somth...

Posted Date: 2023-12-30 10:46     Edited Date: 2023-12-30 10:46     Writer: info

Because it doesn't work now. And Instruction on the website says nothing about the issues.

Posted Date: 2023-12-30 15:14     Edited Date: 2023-12-30 15:14     Writer: sejin

I checked by importing the Unity package.
As you said, the object you loaded and created was not visible in the scene, but when I clicked the load button again, the space object loaded fine.

If the object does not load when you click the load button, I think it is because your computer environment is different from my computer environment.

First of all, if your GPU does not support Rendering.IndexFormat.UInt32, you will not be able to load the object correctly.


Please let us know what version of Unity you are running, your operating system, and the specs of your computer (CPU, GPU, etc.).


If possible, try creating a new project or running it on a different machine to see if it works.

Thank you.



MAXST Support Team

Posted Date: 2023-12-30 19:39     Edited Date: 2023-12-30 19:39     Writer: info

I use Unity 2022.3.5f1, CPU is Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz   2.59 GHz, GPU is NVIDIA GeForce RTX 3060 Laptop GPU

Posted Date: 2023-12-30 20:21     Edited Date: 2023-12-30 20:21     Writer: info

I pressed "Load" few times. It doesn't work

Posted Date: 2023-12-31 3:16     Edited Date: 2023-12-31 3:16     Writer: sejin

I attempted multiple times, but I was unable to reproduce the bug. It appears that the issue may lie within the FileReader.cs > ReadObjectFile function, where it may not be reading vertex, normal, texture, etc. information correctly.

Could you please consider creating a new project and attempting to load it again, or installing Unity on a different computer to see if the issue persists?

As I haven't been able to reproduce the bug on my own computers, it's challenging to identify why the object file is not being read properly. I will dedicate time to investigate further next Monday.

Thank you for your patience.



MAXST Support Team

Posted Date: 2024-01-03 15:34     Edited Date: 2024-01-03 15:34     Writer: info

I created new project and tried again. It doesn't work.

And i tried to use my MacBook and it works there. I can use my mac but why it doens't work on my windows laptop.

Posted Date: 2024-01-03 23:52     Edited Date: 2024-01-04 0:25     Writer: sejin

We have tested on Windows, but have not yet been able to reproduce the bug.
We'll get back to you after testing on a variety of Windows computers.
In the meantime, please let us know if you experience the same bug on other versions of Unity, it will help us find the bug.
Also, please let us know the specs of the RAM on that windows laptop.

Thank you.

Posted Date: 2024-01-04 14:48     Edited Date: 2024-01-04 14:48     Writer: info

I tried in Unity 2019.4.1f1 and it doesn't work there.
I have 32 GB RAM

Posted Date: 2024-01-09 13:44     Edited Date: 2024-01-09 13:44     Writer: info

Hey, do you have any solution for that? And How many people have met it as me?

Posted Date: 2024-01-10 0:08     Edited Date: 2024-01-10 0:08     Writer: sejin

So far, no one else has encountered this problem except you.
We have tried to reproduce the bug on various computers, but it is not reproducible.

Can you please check if you can reproduce it on another Windows PC?
Since the bug is not reproducible at all, it is not something we can debug at this time. If you can, could you please check if the vertices are passing through fine in FileReader.cs > ReadObjectFile function on line 107: (token1, token2, token3)

We apologize for the inconvenience and will do our best to resolve the issue.



MAXST Support Team


Posted Date: 2024-01-10 18:31     Edited Date: 2024-01-10 18:31     Writer: info

I got this messages in console

Posted Date: 2024-01-10 18:32     Edited Date: 2024-01-10 18:32     Writer: info

Unfortunately i don't have another PC

Posted Date: 2024-01-11 19:46     Edited Date: 2024-01-11 19:46     Writer: info

If you can, could you please check if the vertices are passing through fine in FileReader.cs > ReadObjectFile function on line 107: (token1, token2, token3)

How can i check it?

Posted Date: 2024-01-16 1:38     Edited Date: 2024-01-16 1:38     Writer: sejin

We apologize for the delay in responding.
Unfortunately, we have not been able to reproduce the bug and are unable to resolve this issue.

For now, here's how to make sure you're reading the values from the file correctly.

1. Open the file Assets > OBJLoader > FileReader.cs.
2. Breakpoint or take a log at line 107 of FileReader.cs, and verify that token1, token2, and token3 are getting the appropriate values.

3. Verify the values of vn, vt, and f in the same way.

By following the steps above, you should be able to tell if you are reading the OBJ file correctly or not.


MAXST Support Team


Posted Date: 2024-01-27 9:54     Edited Date: 2024-01-27 9:54     Writer: info

Even without debugging it, i can see that values are invalid. Like i texted before i got 999+ messages about invalid values. And you want me to check it. So i have Editor.log file about 1.5 GB size and it's obviously not okay. My program is reading the OBJ file not correctly

Posted Date: 2024-01-28 5:07     Edited Date: 2024-01-29 1:15     Writer: sejin

We apologize for the long wait.
We suspect that the error is a failure to convert a string read from a file to a float.
We realized that TryParse is culture sensitive.
If you give TryParse the option to be culture-insensitive like below, it should work.

float.TryParse(value, System.Globalization.NumberStyles.Float, System.Globalization.CultureInfo.InvariantCulture, out result);

I'll email you the full FileReader.cs, please try replacing the file and let me know the results. Thanks.


MAXST Support Team

Posted Date: 2024-01-29 1:15     Edited Date: 2024-01-29 1:15     Writer: sejin

If possible, can you tell us which country you develop in?


MAXST Support Team

Posted Date: 2024-01-29 12:19     Edited Date: 2024-01-29 12:19     Writer: info


Posted Date: 2024-01-29 13:14     Edited Date: 2024-01-29 13:14     Writer: info

Thank you for help. It works eventually. Replacing FileReader.cs helped.