Try MAXST AR Fusion Tracker Now ✨
List
Object Tracker Problem
Posted Date: 2020-03-17 14:22     Edited Date: 2020-03-19 8:09     Writer: angelia0897

Please provide your development details as below;

1. SDK Version: v 5.01
2. Development Environment: Unity-Android
3. Tracker/Scanner: visual SLAM
4. License Type(Free / Pro-One Time Fee / Pro-Subscription / Enterprise): Free
5. Target Device(Optional): Android Realme 3 pro

We can assist better if you attach screenshots of issues.

Hello MAXST AR Team,

I have a problem when I setup AR for android in Unity, when it's played in Unity. The MAXST AR SDK doesn't show the 3D object in the camera.
Do you have a solution about this problem? I've attached a screenshot.

This  one is a view from Unity camera

 

This is the scene and how the object supposed to be projected



Thank you

Posted Date: 2020-03-17 14:24     Edited Date: 2020-03-17 14:24     Writer: angelia0897

I have followed the instruction as mentioned in this video 
https://www.youtube.com/watch?v=ALRVDH_DkMs&t=319s

Posted Date: 2020-03-17 16:01     Edited Date: 2020-03-17 16:02     Writer: chjee

Hello, angelia0897.

 

It seems to be you have put your 3D objects right below "map viewer". 
However, you should put your objects outside the "map viewer", not inside it. (as a child of "Object Trackable". )

 

Since you can set multiple locations to track, 
objects in the default location(below map viewer) will not be visible. 
You can also check it out in the video,  though it can be easily missed.
( https://youtu.be/ALRVDH_DkMs?t=463 , video you have sent. )

 

I hope this will help.
Please do not hesitate for further support.

 

Connor
Maxst Support Team

Posted Date: 2020-03-18 8:22     Edited Date: 2020-03-18 8:22     Writer: angelia0897

I just did move the 3D object below "map viewer", but the 3D object still doesn't show up

Posted Date: 2020-03-19 2:12     Edited Date: 2020-03-19 2:26     Writer: chjee

Have you set your object's position to (0,0,0)?
If not, your object might be augmented outside the screen.

Or it may be a scale issue, that your perspective are inside the cube,
so that renderer is not rendering. 


Best way to figure it out is to augment our default pin.
By augumenting our default pin, you can figure it out whether
it's an object problem or a script problem.

You might also check our documentation.
https://developer.maxst.com/MD/doc/5_0_x/unity/ex/object

There are several problems that produce the same result
- "Not augumenting properly". It is difficult to know the
exact problem with limited information.
Best option is to record your process and show it to us.
I hope you understand.

Good luck with your project.

 

Connor
Maxst Support Team

Posted Date: 2020-03-19 7:17     Edited Date: 2020-03-19 7:17     Writer: angelia0897

Yes I have set the object to (0,0,0),
I've recorded the process by following the tutorial.
Here is the link:
 https://drive.google.com/file/d/1K9A2zIEZ0TiTcnYtDxcA2a5koKA-w7gF/view?usp=sharing

I tried to change the object into a simple box, but the 3D object still doesn't show up.
If it still doesn't work may I send my project folder to MAXST team? Just to check if there is something wrong.

Thank you  

 

Posted Date: 2020-03-19 8:09     Edited Date: 2020-03-19 8:09     Writer: chjee

First of all, thanks for your effort with your video.

Unfortunately there seems to be no procedural problem.
Did it worked well when you tested your pins in Visual SLAM tool App?

==============
Note.
If not the most likely problem is lack of keyframes.

In VSLAM app while you make 3D map,
yellow colored faces mean that you have achieved minimum keypoints to track.
Even if each side is painted in yellow, 
our VSLAM app continues to learn.
For a higher recognition rate, it is recommended to continue learning
while making various changes in angle and distance.

Check this out.
https://developer.maxst.com/MD/doc/g/vslamguide  

 

Connor
Maxst Support Team