Try MAXST AR Fusion Tracker Now ✨
List
Unity Runtime Error
Posted Date: 2020-11-05 17:08     Edited Date: 2020-11-12 1:34     Writer: brandon

1. 5.0.2
2. Unity Editor
3. Image Tracker
4. Pro-One Time Fee
5. Android / iOS

6.Unity verison: 2019.1.7f1

Hey all!

I am having trouble updating an old maxst project after going back to it a few months later. I decided to try a fresh project to find any SDK related issues and immediately I am confronted with this error. This is  a fresh project trying to Play In Editor the ImageTracker MAXST sample scene. Please see image for error and weird effect on camera.

Any help or insight would be greatly appreciated.

Posted Date: 2020-11-06 7:53     Edited Date: 2020-11-06 7:53     Writer: sjkim

Thanks for your interest in our MAXST AR SDK.

 

We can't understand your exact problem with the text.

 

Is the problem caused by building the sample app of MAXST AR SDK 5.0.2?

So., Could you please share more specific information about your development?

 

If our team can get it we can help you more easily.
 

 

Best regards,

Francisco

MAXST Support Team

Posted Date: 2020-11-06 16:37     Edited Date: 2020-11-06 16:37     Writer: brandon

Yes, this problem happens when I try to run the sample scene of MAXST AR SDK 5.0.2 in the Unity Editor. Also, when I try to run the sample application on an android phone it doesn't request camera permissions and so the camera doesn't initialize.

Does that help?

Posted Date: 2020-11-09 1:33     Edited Date: 2020-11-09 1:36     Writer: sjkim

This error is not related to the MAXST AR SDK.

But, this error is related to problem of MS Visual C++ Runtime Library.

 

You should uninstall all versions of your current C++ Redistributable libraries through your Windows Control Panel.

 

Please reinstall to C++ Redistributable libraries through the bottom link.

https://www.microsoft.com/ko-kr/download/details.aspx?id=14632

 

Finally Please check out the minimum development environment.

Unity :  Unity 2017.1 or later
Android :  JDK 1.8 or later
Android NDK 20.0.5594570 or lastest version Android SDK
iOS :  iOS 9.0 or later
Windows :  Windows 10, Visual Studio 2017 or later

 

 

Best regards,

Francisco

MAXST Support Team

Posted Date: 2020-11-10 16:53     Edited Date: 2020-11-10 16:53     Writer: brandon

Awesome! Thank you! That solved the crash!

Now I am getting these errors about loading MaxstAR.dll and missing dependencies.

I tried the advice from this but no luck so far.

Plugins: Failed to load 'Assets/Plugins/x86_64/MaxstAR.dll' because one or more of its dependencies could not be loaded.
maxstAR.AbstractCameraBackgroundBehaviour:Awake() (at Assets/MaxstAR/Script/Wrapper/AbstractCameraBackgroundBehaviour.cs:71)

Plugins: Failed to load 'Assets/Plugins/x86_64/MaxstAR.dll' because one or more of its dependencies could not be loaded.
maxstAR.MaxstAR:SetScreenOrientation(Int32) (at Assets/MaxstAR/Script/Wrapper/MaxstAR.cs:47)
maxstAR.AbstractCameraBackgroundBehaviour:Awake() (at Assets/MaxstAR/Script/Wrapper/AbstractCameraBackgroundBehaviour.cs:71)

DllNotFoundException: MaxstAR
maxstAR.MaxstAR.SetScreenOrientation (System.Int32 orientation) (at Assets/MaxstAR/Script/Wrapper/MaxstAR.cs:47)
maxstAR.AbstractCameraBackgroundBehaviour.Awake () (at Assets/MaxstAR/Script/Wrapper/AbstractCameraBackgroundBehaviour.cs:71)





I can make a new topic if needed.

Posted Date: 2020-11-12 1:34     Edited Date: 2020-11-12 1:34     Writer: sjkim

Do you have MaxstAR.dll in Assets/Plugins/x86_64?

Please check out.

 

If you have MaxstAR.dll, please update the latest supported Visual C++ redistributable package.

 

Please refer to the bottom link to update Visual C++ redistributable packages

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

 

 

Best regards,

Francisco

MAXST Support Team